Autotrail Cheyenne 630lb 3rd Brake Light

Discussion in 'Tech/Mech General' started by walkingjoyce871, Mar 14, 2015.

  1. walkingjoyce871

    walkingjoyce871

    Joined:
    Jan 19, 2013
    Messages:
    5
    Likes Received:
    5
    Location:
    North Staffs
    3rd brake light not working, have removed the fitting and disconnected it,
    the 7 bulbs are each marked 2.3 E1 can anyone help me in where I can obtain replacement bulbs .
    There is one bulb that may be suspect as it looks cloudy, but does the fact that one bulb not working cause the other bulbs not to work.
    Thanks a lot for any help given
    Jim
     
  2. jockaneezer

    jockaneezer Funster

    Joined:
    Dec 12, 2010
    Messages:
    1,585
    Likes Received:
    3,058
    Location:
    Cumbria
    My high level brake light stopped working, checked the bulbs with my multi meter and one of them had blown, but the main fault was the wiring. It wasn't delivering enough current, probably a corroded connector. Almost impossible to trace so I ran a new cable and soldered it into the offside brake light supply. Do you have access to a multi meter ? I got the replacement lamp from a local car accessories shop.
     
  3. walkingjoyce871

    walkingjoyce871

    Joined:
    Jan 19, 2013
    Messages:
    5
    Likes Received:
    5
    Location:
    North Staffs
    Thanks jockaneezer for your quick response, I have got a multi meter, the bulbs are very tiny but will have a check.
    You say you obtained a replacement lamp from a local car accessories shop, can you give me a description of this lamp.
    Thanks again Jim
     
  4. jockaneezer

    jockaneezer Funster

    Joined:
    Dec 12, 2010
    Messages:
    1,585
    Likes Received:
    3,058
    Location:
    Cumbria
    Hi Jim, sorry for not getting back sooner, been fitting a new aux drive belt on my van. Here's a picture of the type of bulb in my brake light. They are all glass, 2.3 watts and I got them from my local branch of A1 Motorshops. Not sure what your light assembly looks like but I bought a new one from Liesureshop Direct for my Burstner.
     

    Attached Files:

  5. John Laidler

    John Laidler Funster

    Joined:
    Jan 9, 2013
    Messages:
    8,557
    Likes Received:
    11,530
    Location:
    Plympton, Devon
    You need to check if power is getting to the brake light cluster. If not, you will have to try and trace it back.
     
  6. tonyidle

    tonyidle Funster

    Joined:
    Aug 6, 2013
    Messages:
    2,861
    Likes Received:
    2,682
    Location:
    Kendal, Cumbria
  7. walkingjoyce871

    walkingjoyce871

    Joined:
    Jan 19, 2013
    Messages:
    5
    Likes Received:
    5
    Location:
    North Staffs
    My thanks to Funsters jockaneezer, DevonBeekeeper and tonyidle.
    The problem with the 3rd brake light was that the after removing all of the bulbs the connections under the bulbs was found to be corroded, and new bulbs inserted after every socket was cleaned and now the lights are working.
    Once again thank you.
    Jim
     
    • Like Like x 1
  8. Daifuse

    Daifuse

    Joined:
    Feb 20, 2013
    Messages:
    184
    Likes Received:
    310
    Location:
    Milford Haven
    The inside of mine was quite badly corroded due to moisture ingress so I replaced all the bulbs with high brightness leds, all wired in parallel with a series resistor for each led to limit the current. I'm not sure but I think the resistors were 560 ohms. Result was very acceptable.
     
Loading...

Share This Page