12v problem

Discussion in 'The Beginner' started by divad70, Apr 9, 2014.

  1. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    Hiya.. everybody. i need help!! ive got a talbot merlin motorhome.. its old but well loved. its been running fine. but last weekend a problem arised with the 12 volt system. on switching it on the green battery light says fine for 2 seconds. and everythings on!! Then it goes onto red!! Flat!! And switches off!!! And this keeps happening.. on then off!!! Clicks on then clicks off!!! Lights on lights off.. water pump on then water pump off!!!.... PLEASE CUD SOMEBODY HELP!!!! thanks dave.
     
  2. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,207
    Likes Received:
    9,588
    Location:
    Dorset
    what condition is the leisure battery in, what state of charge and how old? do you still get the same when plugged into the mains on hook up?
     
  3. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,450
    Likes Received:
    16,882
    Location:
    YO11 2BD
    my thoughts too.

    Lights pull battery voltage below usable volts, lights go off.
    Unloaded Battery recovers slightly so lights come back on momentarily then drag the volts down and lights go off....again and again.

    New battery by the sound of it..
     
  4. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    Thanks for your reply. i appreciate uve took time out.. tried charging the leisure batt but only putting a very small trickle into it. i think its quite old though!! And yes its still doing it on the mains?? As i explained i put either the lights on or water pump etc.. the green light comes on for 2 seconds then it clicks.goes onto red! And cuts off.. then 4secs later the same sinario??? I probably sound really thick? But electrics r not my field..
     
  5. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,450
    Likes Received:
    16,882
    Location:
    YO11 2BD
    you dont sound thick at all.....if you dont understand how something works or why its doing something you wouldnt expect, you dont know.....we all had to learn somehow.

    all symptoms point to a knackered battery and if, as you say, it does it on hookup i suspect the charger is turned off or not working at all........which would explain the dead battery.

    On hookup the charger doubles up as a 12v power supply as well as charging the battery so even with a dead battery you will have 12v power...if the charge is working.
     
  6. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    So wot your saying is its my battery? Just dont want to spend 60-70 quid on a new one if its not!! Just worried it might b a wire tripping somewhere! As it cums on then goes off.. but keeps rebooting itself? If this is wot happens wen your batt is knackered?? Thank u so much for your HELP!!! priceless..
     
  7. mitzimad

    mitzimad Funster

    Joined:
    Jan 28, 2008
    Messages:
    2,962
    Likes Received:
    3,300
    Location:
    walthamstow east london
    i would check all connections first a dodgy battery terminal will do that
     
  8. Reallyretired

    Reallyretired Funster

    Joined:
    Apr 27, 2008
    Messages:
    5,703
    Likes Received:
    3,208
    Location:
    Eastbourne East Sussex
    I would put a meter on the battery, note voltage, then connect to mains and check voltage again. If voltage does not increase (to around 13.5v) when the mains is on then your charger isn't working (may just be a fuse gone).

    If the battery voltage without the mains is less than 12v then the battery is shot too. I'm afraid it sounds as if both may be the case.

    While doing this you can check the security of the battery terminals.
     
    Last edited: Apr 9, 2014
  9. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    Cheers.. tried that.. got two screws into terminals and red and black wires holding on to terminals.. BUT the red wire is on the - and the blk wire is on +? Strange i know.. but its been working fine for 2 yrs?
     
  10. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    As i explained theres two wires on the leisure batt.. the red wire has a fuse connection.. So possibly trying to overide the CHARGER??? From 12 v .. van battery.. so phaps charger knackered?? And trying to charge leisure batt. just off normal altanater??? Which main batt was flat over the winter!!! I dont know i just guessing??? Thanks for your all thoughts...
     
  11. divad70

    divad70 Read Only Funster

    Joined:
    Apr 9, 2014
    Messages:
    6
    Likes Received:
    0
    Location:
    west midlands
    If somebody could b kind nuf to send me there email addy i cud send some pics how its wired up!!! And maybe put an end to this mind blowing elec prob..... thanks.
     
Loading...

Share This Page